US-CERT Technical Cyber Security Alert TA04-245A -- Multiple Vulnerabilities in Oracle Products

02/09/04, US-CERT Technical Cyber Security Alert TA04-245A -- Multiple Vulnerabilities in Oracle Products
From: CERT Advisory <cert-advisory@cert.org>

Generated by MHonArc

CSIM Logo WelcomeCourses
Faculty, Student, Staff
Projects and reports
Conferences, workshop and seminars
Laboratories and reasearch facilities
Information related to CSIM
Information non-related to CSIM
Address, map, phone, etc.
Search

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]


To: cert-advisory@cert.org
Subject: US-CERT Technical Cyber Security Alert TA04-245A -- Multiple Vulnerabilities in Oracle Products
From: CERT Advisory <cert-advisory@cert.org>
Date: Wed, 1 Sep 2004 16:04:34 -0400
List-archive: <http://www.cert.org/>
List-help: <http://www.cert.org/>, <mailto:Majordomo@cert.org?body=help>
List-owner: <mailto:cert-advisory-owner@cert.org>
List-post: NO (posting not allowed on this list)
List-unsubscribe: <mailto:Majordomo@cert.org?body=unsubscribe%20cert-advisory>
Mail-from: From nobody@cert.org Thu Sep 2 03:57:17 2004
Organization: CERT(R) Coordination Center - +1 412-268-7090

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

             Technical Cyber Security Alert TA04-245A
            Multiple Vulnerabilities in Oracle Products

   Original release date: September 1, 2004
   Last revised: --
   Source: US-CERT

Systems Affected

   The following Oracle applications are affected:

     * Oracle Database 10g Release 1, version 10.1.0.2
     * Oracle9i Database Server Release 2, versions 9.2.0.4 and 9.2.0.5
     * Oracle9i Database Server Release 1, versions 9.0.1.4, 9.0.1.5 and
       9.0.4
     * Oracle8i Database Server Release 3, version 8.1.7.4
     * Oracle Enterprise Manager Grid Control 10g, version 10.1.0.2
     * Oracle Enterprise Manager Database Control 10g, version 10.1.0.2
     * Oracle Application Server 10g (9.0.4), versions 9.0.4.0 and
       9.0.4.1
     * Oracle9i Application Server Release 2, versions 9.0.2.3 and
       9.0.3.1
     * Oracle9i Application Server Release 1, version 1.0.2.2

   Oracle's Collaboration Suite and E-Business Suite 11i contain some of
   the vulnerable components and are also affected.

   According to Oracle, the following product releases and versions, and
   all future releases and versions are not affected:

     * Oracle Database 10g Release 1, version 10.1.0.3
     * Oracle Enterprise Manager Grid Control 10g, version 10.1.0.3 (not
       yet available)
     * Oracle Application Server 10g (9.0.4), version 9.0.4.2 (not yet
       available)

Overview

   Several vulnerabilities exist in the Oracle Database Server,
   Application Server, and Enterprise Manager software. The most serious
   vulnerabilities could allow a remote attacker to execute arbitrary
   code on an affected system. Oracle's Collaboration Suite and
   E-Business Suite 11i contain the vulnerable software and are affected
   as well.

I. Description

   Several vulnerabilities have been reported in Oracle's Database
   Server, Application Server, and Enterprise Manager software. According
   to reports, several buffer overflow, format string, SQL injection and
   other types of vulnerabilities were discovered and reported to Oracle.

   Oracle has released Oracle Security Alert #68 (pdf) to address these
   vulnerabilities. We are tracking them as follows:

     VU#170830 - Oracle Enterprise Manager contains several
     vulnerabilities

     VU#316206 - Oracle Database Server contains several vulnerabilities

     VU#435974 - Oracle Application Server contains several
     vulnerabilities

   As more information becomes available, we will update these
   vulnerability notes as appropriate.

II. Impact

   The impacts of the vulnerabilities described above are unclear.

   According to credible reports, the impacts of these vulnerabilities
   range from the remote unauthenticated execution arbitrary code to data
   corruption or leakage.

III. Solution

Apply a patch or upgrade

   Apply the appropriate patch or upgrade as specified in the Oracle
   Security Alert #68 (pdf).

   Organizations that use Oracle's Collaboration Suite or E-Business
   Suite 11i should see Oracle Security Alert #68 (pdf) for remediation
   instructions.

Appendix A. References

     * Oracle Security Alert #68 (pdf) - <
       http://www.oracle.com/technology/deploy/security/pdf/2004alert68.p
       df>
     * US-CERT Vulnerability Note VU#316206 -
       <http://www.kb.cert.org/vuls/id/316206>
     * US-CERT Vulnerability Note VU#435974 -
       <http://www.kb.cert.org/vuls/id/435974>
     * US-CERT Vulnerability Note VU#170830 -
       <http://www.kb.cert.org/vuls/id/170830>
  _________________________________________________________________

   US-CERT thanks all the parties involved in researching and reporting
   these vulnerabilities. Specifically, Oracle credits the people for
   discovering these issues: David Litchfield, Michael Litchfield, Cesar
   Cerrudo, Pete Finnigan, Jonathan Gennick, Alexander Kornbrust, Stephen
   Kost, Matt Moore, Aaron Newman, Andy Rees, and Christian Schaller.
  _________________________________________________________________

   Feedback can be directed to the author: Jason A. Rafail.
  _________________________________________________________________
   
   This document is available from:
   
      <http://www.us-cert.gov/cas/techalerts/TA04-245A.html>
   
  _________________________________________________________________

   Copyright 2004 Carnegie Mellon University.
   
   Terms of use: <http://www.us-cert.gov/legal.html>
  _________________________________________________________________

   Revision History

   Sep 1, 2004: Initial release

                      Last updated September 01, 2004 
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQFBNihCXlvNRxAkFWARAplJAJ9AROpSu/1ykM0LkIcpnoADxTKHFwCgtE4b
OLKV86pUUBI7/iE2GVtHA8s=
=M7Dk
-----END PGP SIGNATURE-----



Previous message sorted by date: US-CERT Technical Cyber Security Alert TA04-217A -- Multiple Vulnerabilities in libpng
Next message sorted by date: US-CERT Technical Cyber Security Alert TA04-247A -- Vulnerabilities in MIT Kerberos 5
Previous message sorted by thread: US-CERT Technical Cyber Security Alert TA04-217A -- Multiple Vulnerabilities in libpng
Next message by thread: US-CERT Technical Cyber Security Alert TA04-247A -- Vulnerabilities in MIT Kerberos 5
Main Index
Thread Index

CSIM home pageWMailAccount managementCSIM LibraryNetwork test toolsSearch CSIM directories
Contact us: Olivier Nicole CSIM    SET    AIT Last update: Sep 2004